summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLoic Blot <loic.blot@unix-experience.fr>2017-05-26 17:03:46 +0200
committerLoïc Blot <nerzhul@users.noreply.github.com>2017-06-04 09:57:08 +0200
commitbf6569b57019d070246d947ed929cb2b5eb67faf (patch)
tree3a8a3d4858f20a57930e0a0d0ad1f7c3fb48b512 /CMakeLists.txt
parent0e58168fe5bce607f64805b854420e7558372f24 (diff)
downloadminetest-bf6569b57019d070246d947ed929cb2b5eb67faf.tar.gz
minetest-bf6569b57019d070246d947ed929cb2b5eb67faf.tar.bz2
minetest-bf6569b57019d070246d947ed929cb2b5eb67faf.zip
Minetest for C++11 (CMakeLists + Travis)
* Move GCC to GCC 6 & GCC 7 * Move Clang to Clang 3.6 & Clang 4.0 * LINT moves from Clang 3.9 to Clang 4.0 * Move XCode 7.3 to 8.0 * Use more travis tricks to install compilers instead of adding complexity to our build script * Clang format fixes on checked files (compat Cpp11 instead of Cpp03) * Mingw GCC update from 4.8.4 to 5.3 (Ubuntu Xenial) * Drop mingw cmake generated files and add them to gitignore
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 763d554b9..5494c91b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,8 @@ endif()
project(minetest)
set(PROJECT_NAME_CAPITALIZED "Minetest")
+# Works only for cmake 3.1 and greater
+set(CMAKE_CXX_STANDARD 11)
# Also remember to set PROTOCOL_VERSION in network/networkprotocol.h when releasing
set(VERSION_MAJOR 0)