summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsfan5 <sfan5@live.de>2014-07-29 10:47:38 +0200
committersfan5 <sfan5@live.de>2014-07-29 20:03:18 +0200
commit17345404bad71989238d492ed2e23c97f5681065 (patch)
tree6d688df0d1e9d4055187b233b76549e3956c30ea /CMakeLists.txt
parent5884236046c4405eec7cfc12cdde0be9f48058b6 (diff)
downloadminetest-17345404bad71989238d492ed2e23c97f5681065.tar.gz
minetest-17345404bad71989238d492ed2e23c97f5681065.tar.bz2
minetest-17345404bad71989238d492ed2e23c97f5681065.zip
Add ZLIBWAPI_DLL and LEVELDB_DLL CMake options Remove legacy MINGWM10_DLL CMake option Update 32-bit buildbot (OpenAL updated, zlib updated) Change build directory for buildbots to '_build' to prevent removal of Android build files Use -win64 suffix for 64-bit Windows builds Fixes #1476
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2050e57a6..5e234eedf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -202,7 +202,11 @@ if(WIN32)
# install(FILES bin/minetestserver.exe DESTINATION bin)
#endif()
- set(CPACK_PACKAGE_FILE_NAME "${PROJECT_NAME}-${VERSION_STRING}-win32")
+ if(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ set(CPACK_PACKAGE_FILE_NAME "${PROJECT_NAME}-${VERSION_STRING}-win64")
+ else(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ set(CPACK_PACKAGE_FILE_NAME "${PROJECT_NAME}-${VERSION_STRING}-win32")
+ endif(CMAKE_SIZEOF_VOID_P EQUAL 8)
set(CPACK_GENERATOR ZIP)