summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbigfoot547 <bigfoot547@users.noreply.github.com>2017-05-17 02:41:41 -0500
committerLoïc Blot <nerzhul@users.noreply.github.com>2017-05-17 09:41:41 +0200
commit287605ca8151f68224c919f45e2ae425cf6849a9 (patch)
tree97b6b99dbdc0024a3bb2f0192ca36d53f0e055f8 /CMakeLists.txt
parent0120fe16a761f9e06c8c2877439db6a46d808143 (diff)
downloadminetest-287605ca8151f68224c919f45e2ae425cf6849a9.tar.gz
minetest-287605ca8151f68224c919f45e2ae425cf6849a9.tar.bz2
minetest-287605ca8151f68224c919f45e2ae425cf6849a9.zip
Append -debug to version string (#5765)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 418856460..09906f895 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,11 @@ elseif(DEVELOPMENT_BUILD)
set(VERSION_STRING "${VERSION_STRING}-dev")
endif()
+if (CMAKE_BUILD_TYPE STREQUAL Debug)
+ # Append "-debug" to version string
+ set(VERSION_STRING "${VERSION_STRING}-debug")
+endif()
+
message(STATUS "*** Will build version ${VERSION_STRING} ***")