summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorest31 <MTest31@outlook.com>2016-03-16 13:21:34 +0100
committerest31 <MTest31@outlook.com>2016-03-16 23:06:33 +0100
commit3132bcb3732df51c08c8b2f34781e463cd94fe7f (patch)
tree77bdb8ae64de8c1b719db5571b7910fcd1e19bbd /CMakeLists.txt
parent095f623fa7278375a6fa4fe01ed39d2b68cce7af (diff)
downloadminetest-3132bcb3732df51c08c8b2f34781e463cd94fe7f.tar.gz
minetest-3132bcb3732df51c08c8b2f34781e463cd94fe7f.tar.bz2
minetest-3132bcb3732df51c08c8b2f34781e463cd94fe7f.zip
Set EXAMPLE_CONF_DIR to DOCDIR if DOCDIR gets customized
Before, customisation of DOCDIR did not lead to changes of the EXAMPLE_CONF_DIR default value. This was inconsistent with expected behaviour if you didn't know of the existence of the EXAMPLE_CONF_DIR variable. The confusion is very strong, as (for not in place builds) both DOCDIR and EXAMPLE_CONF_DIR share the same default value, it is unexpected that setting CUSTOM_DOCDIR changes the location of all documentation files but one. The best meaning of EXAMPLE_CONF_DIR is to further allow customization of the mt.conf.example storage place, but otherwise keep defaulting to whatever DOCDIR is set to, at least for not in place builds. This patch implements that behaviour. Fixes #3863.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8278522e..3f853f4dd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,6 +113,9 @@ endif()
set(CUSTOM_DOCDIR "" CACHE STRING "Directory to install documentation into")
if(NOT CUSTOM_DOCDIR STREQUAL "")
set(DOCDIR "${CUSTOM_DOCDIR}")
+ if(NOT RUN_IN_PLACE)
+ set(EXAMPLE_CONF_DIR ${DOCDIR})
+ endif()
message(STATUS "Using DOCDIR=${DOCDIR}")
endif()