summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKahrl <kahrl@gmx.net>2013-09-25 04:29:07 +0200
committerKahrl <kahrl@gmx.net>2013-09-28 21:30:17 +0200
commit8bc7ea61b901516d3e1cbde77df1830d14129259 (patch)
treee7acea045324fc70dcce0547e34ebc6d958bf1c1 /CMakeLists.txt
parent372d638ec1ea97bf88e9d62ffeb03e73bc94ee1e (diff)
downloadminetest-8bc7ea61b901516d3e1cbde77df1830d14129259.tar.gz
minetest-8bc7ea61b901516d3e1cbde77df1830d14129259.tar.bz2
minetest-8bc7ea61b901516d3e1cbde77df1830d14129259.zip
Show git hash in version string at top left corner of window
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2db4e4a76..f9fff75db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,9 @@ set(VERSION_MINOR 4)
set(VERSION_PATCH 7)
if(VERSION_EXTRA)
set(VERSION_PATCH ${VERSION_PATCH}-${VERSION_EXTRA})
+else()
+ # Comment the following line during release
+ set(VERSION_PATCH ${VERSION_PATCH}-dev)
endif()
set(VERSION_STRING "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}")