summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPavel Puchkin <i@neoascetic.me>2015-03-13 13:09:58 +0200
committersfan5 <sfan5@live.de>2016-01-09 16:50:04 +0100
commitfe3f6be4d262b466cd511595ad3b3c9bd5c89ea1 (patch)
tree839058dbd4f3dc82603db4112bcab8b6b3a88e5f /CMakeLists.txt
parent7510e0b55187c674adc14ac59e1bf8c574911ee3 (diff)
downloadminetest-fe3f6be4d262b466cd511595ad3b3c9bd5c89ea1.tar.gz
minetest-fe3f6be4d262b466cd511595ad3b3c9bd5c89ea1.tar.bz2
minetest-fe3f6be4d262b466cd511595ad3b3c9bd5c89ea1.zip
Simplify custom games packaging
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea41d0d2f..f8278522e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -149,16 +149,9 @@ endif()
install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/builtin" DESTINATION "${SHAREDIR}")
install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/client" DESTINATION "${SHAREDIR}")
-install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/games/minimal" DESTINATION "${SHAREDIR}/games")
-set(MINETEST_GAME_SOURCE "${CMAKE_CURRENT_SOURCE_DIR}/games/minetest_game")
-if(EXISTS ${MINETEST_GAME_SOURCE} AND IS_DIRECTORY ${MINETEST_GAME_SOURCE})
- install(FILES ${MINETEST_GAME_SOURCE}/game.conf DESTINATION "${SHAREDIR}/games/minetest_game/")
- install(FILES ${MINETEST_GAME_SOURCE}/README.txt DESTINATION "${SHAREDIR}/games/minetest_game/")
- install(DIRECTORY ${MINETEST_GAME_SOURCE}/mods DESTINATION "${SHAREDIR}/games/minetest_game")
- install(DIRECTORY ${MINETEST_GAME_SOURCE}/menu DESTINATION "${SHAREDIR}/games/minetest_game")
-endif()
+install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/games" DESTINATION "${SHAREDIR}" PATTERN ".git*" EXCLUDE)
+
if(BUILD_CLIENT)
- #install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/sounds/base/pack" DESTINATION "${SHAREDIR}/sounds/base")
install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/textures/base/pack" DESTINATION "${SHAREDIR}/textures/base")
endif()
if(RUN_IN_PLACE)