summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLoic Blot <loic.blot@unix-experience.fr>2017-04-07 23:56:02 +0200
committerLoic Blot <loic.blot@unix-experience.fr>2017-04-07 23:56:02 +0200
commitff4fef570e8df6ce44ceb1d9071f860474eb1f95 (patch)
tree601fc6ddfe72106f82e2ec6bac1c9abf854bccfa /CMakeLists.txt
parent4af99b75cf3ae43c365a4c1e90e85f8ec764cf62 (diff)
downloadminetest-ff4fef570e8df6ce44ceb1d9071f860474eb1f95.tar.gz
minetest-ff4fef570e8df6ce44ceb1d9071f860474eb1f95.tar.bz2
minetest-ff4fef570e8df6ce44ceb1d9071f860474eb1f95.zip
Fix cmake library default build problem since moving to lib/
Also make Lua library check a cmake module
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa7deaa11..418856460 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -186,11 +186,14 @@ if(APPLE)
install(FILES "misc/Info.plist" DESTINATION "${BUNDLE_PATH}/Contents")
endif()
+# Library pack
+find_package(GMP REQUIRED)
+find_package(Json REQUIRED)
+find_package(Lua REQUIRED)
# Subdirectories
# Be sure to add all relevant definitions above this
-add_subdirectory(lib)
add_subdirectory(src)