summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPerttu Ahola <celeron55@gmail.com>2011-01-09 17:28:31 +0200
committerPerttu Ahola <celeron55@gmail.com>2011-01-09 17:28:31 +0200
commit56918c0ca47582c425e56017115df852df1fa886 (patch)
tree8b31005fcb99a236fea902a3d19f65fb236c9bb4 /CMakeLists.txt
parent359e575ba377fa83317cd733f0c5eefdc0a8ff59 (diff)
downloadminetest-56918c0ca47582c425e56017115df852df1fa886.tar.gz
minetest-56918c0ca47582c425e56017115df852df1fa886.tar.bz2
minetest-56918c0ca47582c425e56017115df852df1fa886.zip
random build system tweaking
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 106975a67..dc9d98b36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,11 @@ set(VERSION_STRING "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}")
# Configuration options
-set(RUN_IN_PLACE 0 CACHE BOOL "Run directly in source directory structure")
+if(WIN32)
+ set(RUN_IN_PLACE 1 CACHE BOOL "Run directly in source directory structure")
+else()
+ set(RUN_IN_PLACE 0 CACHE BOOL "Run directly in source directory structure")
+endif()
set(BUILD_CLIENT 1 CACHE BOOL "Build client")
set(BUILD_SERVER 1 CACHE BOOL "Build server")
@@ -68,6 +72,7 @@ set(CPACK_PACKAGE_VERSION_MAJOR ${VERSION_MAJOR})
set(CPACK_PACKAGE_VERSION_MINOR ${VERSION_MINOR})
set(CPACK_PACKAGE_VERSION_PATCH ${VERSION_PATCH})
set(CPACK_PACKAGE_VENDOR "celeron55")
+set(CPACK_PACKAGE_CONTACT "Perttu Ahola <celeron55@gmail.com>")
if(WIN32)
# For some reason these aren't copied otherwise
@@ -87,7 +92,6 @@ if(WIN32)
elseif(APPLE)
# TODO
# see http://cmake.org/Wiki/CMake:CPackPackageGenerators#Bundle_.28OSX_only.29
- # this too http://0xfe.blogspot.com/2006/03/how-os-x-executes-applications.html
#
set(CPACK_PACKAGE_FILE_NAME "${PROJECT_NAME}-${VERSION_STRING}-osx")
set(CPACK_PACKAGE_ICON "")