summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
author20kdc <asdd2808@gmail.com>2021-09-05 18:57:40 +0100
committerGitHub <noreply@github.com>2021-09-05 19:57:40 +0200
commita3e32d81c5292c304b85efeeb3cf2227d6ddf191 (patch)
tree574ce655efa429b94efd89ea909990262f00546e /CMakeLists.txt
parentff9945dc6eb33d054059fc48605ffea7c4b515d3 (diff)
downloadminetest-a3e32d81c5292c304b85efeeb3cf2227d6ddf191.tar.gz
minetest-a3e32d81c5292c304b85efeeb3cf2227d6ddf191.tar.bz2
minetest-a3e32d81c5292c304b85efeeb3cf2227d6ddf191.zip
Add hint to error message on how to build with in-tree Irrlicht
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65c6bf6c3..1995f34b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,7 +86,8 @@ else()
if(NOT TARGET IrrlichtMt::IrrlichtMt)
string(CONCAT explanation_msg
"The Minetest team has forked Irrlicht to make their own customizations. "
- "It can be found here: https://github.com/minetest/irrlicht")
+ "It can be found here: https://github.com/minetest/irrlicht\n"
+ "For example use: git clone --depth=1 https://github.com/minetest/irrlicht lib/irrlichtmt\n")
if(BUILD_CLIENT)
message(FATAL_ERROR "IrrlichtMt is required to build the client, but it was not found.\n${explanation_msg}")
endif()