summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSmallJoker <SmallJoker@users.noreply.github.com>2022-08-02 21:34:17 +0200
committerGitHub <noreply@github.com>2022-08-02 21:34:17 +0200
commita81259d19a434752614e5a430fdebf86f07c1cfc (patch)
treefcb83c0aa14c645c0050d683b54131bc598556f3 /CMakeLists.txt
parentf22d40975e907d9f0e84b67b21256953333a6cc8 (diff)
downloadminetest-a81259d19a434752614e5a430fdebf86f07c1cfc.tar.gz
minetest-a81259d19a434752614e5a430fdebf86f07c1cfc.tar.bz2
minetest-a81259d19a434752614e5a430fdebf86f07c1cfc.zip
Run Minetest update checker on startup (#7629)
This feature is enabled by default for non-Android release builds. Package maintainers may use -DENABLE_UPDATE_CHECKER=0 to disable it. Co-authored-by: rubenwardy <rw@rubenwardy.com> Co-authored-by: sfan5 <sfan5@live.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9bec15c1b..c96b76fe8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,6 +61,9 @@ if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE Release CACHE STRING "Build type: Debug or Release" FORCE)
endif()
+set(ENABLE_UPDATE_CHECKER (NOT ${DEVELOPMENT_BUILD}) CACHE BOOL
+ "Whether to enable update checks by default")
+
# Included stuff
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")