summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Blot <nerzhul@users.noreply.github.com>2017-04-02 10:51:50 +0200
committerGitHub <noreply@github.com>2017-04-02 10:51:50 +0200
commit86b1542181a92841d174e1caec94d084a34e5158 (patch)
treef18378dd6aa5959b28c5ff8eed19084a288acd1d /lib/CMakeLists.txt
parent75fb3e47308823cf39d4aae0fd739ca445e8e36c (diff)
downloadminetest-86b1542181a92841d174e1caec94d084a34e5158.tar.gz
minetest-86b1542181a92841d174e1caec94d084a34e5158.tar.bz2
minetest-86b1542181a92841d174e1caec94d084a34e5158.zip
Update embedded jsoncpp from unk version to 0.10.6 + move libs to lib/ instead of src/ (#5473)
* Update embedded jsoncpp from unk version to 0.10.6 0.10.6 is last release without c++11 * Make jsoncpp more compliant with its amalgamate Jsoncpp cpp file should be upper, make the library like it does in amalgamate * Reorganization: move minetest embedded libs outside of source tree to /lib * Fix a dead grep in LINT
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
new file mode 100644
index 000000000..32d914720
--- /dev/null
+++ b/lib/CMakeLists.txt
@@ -0,0 +1,23 @@
+# LuaJIT
+option(ENABLE_LUAJIT "Enable LuaJIT support" TRUE)
+set(USE_LUAJIT FALSE PARENT_SCOPE)
+if(ENABLE_LUAJIT)
+ find_package(LuaJIT)
+ if(LUAJIT_FOUND)
+ set(USE_LUAJIT TRUE)
+ set(USE_LUAJIT TRUE PARENT_SCOPE)
+ message (STATUS "Using LuaJIT provided by system.")
+ endif(LUAJIT_FOUND)
+else()
+ message (STATUS "LuaJIT detection disabled! (ENABLE_LUAJIT=0)")
+endif()
+
+if(NOT USE_LUAJIT)
+ message(STATUS "LuaJIT not found, using bundled Lua.")
+ set(LUA_LIBRARY lua PARENT_SCOPE)
+ set(LUA_INCLUDE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/lua/src PARENT_SCOPE)
+ add_subdirectory(lua)
+endif()
+
+find_package(GMP REQUIRED)
+find_package(Json REQUIRED)