summaryrefslogtreecommitdiff
path: root/lib/jsoncpp/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Blot <nerzhul@users.noreply.github.com>2017-04-02 10:51:50 +0200
committerGitHub <noreply@github.com>2017-04-02 10:51:50 +0200
commit86b1542181a92841d174e1caec94d084a34e5158 (patch)
treef18378dd6aa5959b28c5ff8eed19084a288acd1d /lib/jsoncpp/CMakeLists.txt
parent75fb3e47308823cf39d4aae0fd739ca445e8e36c (diff)
downloadminetest-86b1542181a92841d174e1caec94d084a34e5158.tar.gz
minetest-86b1542181a92841d174e1caec94d084a34e5158.tar.bz2
minetest-86b1542181a92841d174e1caec94d084a34e5158.zip
Update embedded jsoncpp from unk version to 0.10.6 + move libs to lib/ instead of src/ (#5473)
* Update embedded jsoncpp from unk version to 0.10.6 0.10.6 is last release without c++11 * Make jsoncpp more compliant with its amalgamate Jsoncpp cpp file should be upper, make the library like it does in amalgamate * Reorganization: move minetest embedded libs outside of source tree to /lib * Fix a dead grep in LINT
Diffstat (limited to 'lib/jsoncpp/CMakeLists.txt')
-rw-r--r--lib/jsoncpp/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/jsoncpp/CMakeLists.txt b/lib/jsoncpp/CMakeLists.txt
new file mode 100644
index 000000000..9056e4b6d
--- /dev/null
+++ b/lib/jsoncpp/CMakeLists.txt
@@ -0,0 +1,7 @@
+if(MSVC)
+ set(CMAKE_CXX_FLAGS_RELEASE "/MT /O2 /Ob2 /D NDEBUG")
+endif()
+
+add_library(jsoncpp jsoncpp.cpp)
+target_link_libraries(jsoncpp)
+