summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authoradrido <robots_only_adrido@gmx.com>2018-10-26 21:37:51 +0200
committerSmallJoker <SmallJoker@users.noreply.github.com>2018-10-26 21:37:51 +0200
commit2322078fe480a338422b35ee29fee3c0767f3e1d (patch)
tree3c935142cc66f0f237d8a6211ae09075fab62bab /src/CMakeLists.txt
parent45b52f6d5a7c8389da8f4cb5c5294a430255a248 (diff)
downloadminetest-2322078fe480a338422b35ee29fee3c0767f3e1d.tar.gz
minetest-2322078fe480a338422b35ee29fee3c0767f3e1d.tar.bz2
minetest-2322078fe480a338422b35ee29fee3c0767f3e1d.zip
Windows: Cpack wix installer (#6153)
Create CPack WIX msi Installer for RUN_IN_PLACE=0 builds Correct paths on Windows for RUN_IN_PLACE=0 Install only required font files Games have their own components, and "minimal" is optional
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 05446c084..c0832d0c2 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -696,7 +696,7 @@ if(MSVC)
# Visual Studio
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /D WIN32_LEAN_AND_MEAN /MP")
# EHa enables SEH exceptions (used for catching segfaults)
- set(CMAKE_CXX_FLAGS_RELEASE "/EHa /Ox /GL /FD /MT /GS- /Zi /fp:fast /D NDEBUG /D _HAS_ITERATOR_DEBUGGING=0 /TP")
+ set(CMAKE_CXX_FLAGS_RELEASE "/EHa /Ox /GL /FD /MD /GS- /Zi /fp:fast /D NDEBUG /D _HAS_ITERATOR_DEBUGGING=0 /TP")
if(CMAKE_SIZEOF_VOID_P EQUAL 4)
set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /arch:SSE")
endif()
@@ -714,8 +714,8 @@ if(MSVC)
set(CMAKE_CXX_FLAGS_DEBUG "/MDd /Zi /Ob0 /Od /RTC1")
# Flags for C files (sqlite)
- # /MT = Link statically with standard library stuff
- set(CMAKE_C_FLAGS_RELEASE "/O2 /Ob2 /MT")
+ # /MD = dynamically link to MSVCRxxx.dll
+ set(CMAKE_C_FLAGS_RELEASE "/O2 /Ob2 /MD")
else()
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
# Probably GCC
@@ -828,6 +828,14 @@ if(BUILD_CLIENT)
endforeach()
endif()
+ if(USE_FREETYPE)
+ install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/../fonts" DESTINATION "${SHAREDIR}"
+ FILES_MATCHING PATTERN "*.ttf" PATTERN "*.txt")
+ else()
+ install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/../fonts" DESTINATION "${SHAREDIR}"
+ FILES_MATCHING PATTERN "*.png" PATTERN "*.xml")
+ endif()
+
if(WIN32)
if(DEFINED IRRLICHT_DLL)
install(FILES ${IRRLICHT_DLL} DESTINATION ${BINDIR})