summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKahrl <kahrl@gmx.net>2011-09-15 01:11:18 +0200
committerPerttu Ahola <celeron55@gmail.com>2011-09-16 19:06:45 +0300
commit40707e3c5bc730ebc5780b1c545c5daeb3353a42 (patch)
treebfa58367cecc5d0f2da34bd19b91904010c95e98 /src/CMakeLists.txt
parent7f51bccf477460d94e8c7775d29848f6f5597a96 (diff)
downloadminetest-40707e3c5bc730ebc5780b1c545c5daeb3353a42.tar.gz
minetest-40707e3c5bc730ebc5780b1c545c5daeb3353a42.tar.bz2
minetest-40707e3c5bc730ebc5780b1c545c5daeb3353a42.zip
SQLite needs to be linked with -ldl on some Linux distros.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9c3b0960a..c479b4e73 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -74,7 +74,7 @@ else()
endif(APPLE)
endif(BUILD_CLIENT)
find_package(ZLIB REQUIRED)
- set(PLATFORM_LIBS -lpthread)
+ set(PLATFORM_LIBS -lpthread ${CMAKE_DL_LIBS})
#set(CLIENT_PLATFORM_LIBS -lXxf86vm)
# This way Xxf86vm is found on OpenBSD too
find_library(XXF86VM_LIBRARY Xxf86vm)