summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authornOOb3167 <nOOb3167@gmail.com>2018-02-19 15:01:10 +0100
committerSmallJoker <SmallJoker@users.noreply.github.com>2018-02-23 17:02:02 +0100
commit4118e150f8841a507e3fcb546902d1e07150e4a2 (patch)
tree561444b39d3a307af0de5ba4195c00c70fa1421c /src/CMakeLists.txt
parentcbf891ef1db7d3b3d1155916c100011d3e9a94cd (diff)
downloadminetest-4118e150f8841a507e3fcb546902d1e07150e4a2.tar.gz
minetest-4118e150f8841a507e3fcb546902d1e07150e4a2.tar.bz2
minetest-4118e150f8841a507e3fcb546902d1e07150e4a2.zip
CMakeLists use the source_group command to improve look and feel when generating Visual Studio projects.
The TREE argument of source_group appears in CMake 3.8 therefore check for version.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e7759b7a7..f38022c5d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -530,6 +530,11 @@ set(server_SRCS
)
list(SORT server_SRCS)
+if ((CMAKE_VERSION VERSION_GREATER 3.8) OR (CMAKE_VERSION VERSION_EQUAL 3.8))
+ source_group(TREE ${PROJECT_SOURCE_DIR} PREFIX "Source Files" FILES ${client_SRCS})
+ source_group(TREE ${PROJECT_SOURCE_DIR} PREFIX "Source Files" FILES ${server_SRCS})
+endif()
+
include_directories(
${PROJECT_BINARY_DIR}
${PROJECT_SOURCE_DIR}