summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPerttu Ahola <celeron55@gmail.com>2011-07-31 00:39:43 +0300
committerPerttu Ahola <celeron55@gmail.com>2011-07-31 00:39:43 +0300
commit05d0eaf5fc4947081ae743a58e8675991e3f2422 (patch)
treeb04446704ea2aba0b290fe8203f368bc220afa45 /src/CMakeLists.txt
parenta114f2800616108523311f1ab6f56a444a687224 (diff)
downloadminetest-05d0eaf5fc4947081ae743a58e8675991e3f2422.tar.gz
minetest-05d0eaf5fc4947081ae743a58e8675991e3f2422.tar.bz2
minetest-05d0eaf5fc4947081ae743a58e8675991e3f2422.zip
added windows icon
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8ce69b2ad..9bb266784 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -128,6 +128,11 @@ set(common_SRCS
base64.cpp
)
+# This gives us the icon
+if(WIN32 AND MSVC)
+ set(common_SRCS ${common_SRCS} winresource.rc)
+endif()
+
# Client sources
set(minetest_SRCS
${common_SRCS}