summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorred-001 <red-001@outlook.ie>2017-01-20 22:19:41 +0000
committerLoïc Blot <nerzhul@users.noreply.github.com>2017-01-20 23:19:41 +0100
commit0dada51a550c5eb52faf700dcbde4cee22a6bc70 (patch)
treeffc0993e7dd2cf240caa382a922291729aee1512 /src/CMakeLists.txt
parentefa54f9c460239c23a2014076764d6c6830589e6 (diff)
downloadminetest-0dada51a550c5eb52faf700dcbde4cee22a6bc70.tar.gz
minetest-0dada51a550c5eb52faf700dcbde4cee22a6bc70.tar.bz2
minetest-0dada51a550c5eb52faf700dcbde4cee22a6bc70.zip
Remove `mathconstants.h` and use the correct way to get `M_PI` in MSVC. (#5072)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f90542be9..cab5a1139 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -284,6 +284,8 @@ if(WIN32)
set(PLATFORM_LIBS dbghelp.lib ${PLATFORM_LIBS})
# Surpress some useless warnings
add_definitions ( /D "_CRT_SECURE_NO_DEPRECATE" /W1 )
+ # Get M_PI to work
+ add_definitions(/D "_USE_MATH_DEFINES")
else() # Probably MinGW = GCC
set(PLATFORM_LIBS "")
endif()