summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoic Blot <loic.blot@unix-experience.fr>2015-02-10 21:14:24 +0100
committerLoic Blot <loic.blot@unix-experience.fr>2015-02-12 15:00:03 +0100
commit146f77fdb750833c649de7159a0833c398e14a4d (patch)
tree05314d9cae6215ecd418e98fa4fe8e31b2632f0c /src/CMakeLists.txt
parent92d1985802b9b5c8a8ca3540221b078fcaadb697 (diff)
downloadminetest-146f77fdb750833c649de7159a0833c398e14a4d.tar.gz
minetest-146f77fdb750833c649de7159a0833c398e14a4d.tar.bz2
minetest-146f77fdb750833c649de7159a0833c398e14a4d.zip
main.cpp rework * Move ClientLauncher class to a dedicated file * ClientLauncher now owns print_video_modes and speed_tests functions (they are only called by him) * Move GameParams to shared/gameparams.h because it's shared between server and client and launcher need to know it * Move InputHandlers class to client/inputhandler.h * Cleanup includes
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e5245534c..23a59ed2d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -494,6 +494,7 @@ set(minetest_SRCS
sky.cpp
tile.cpp
wieldmesh.cpp
+ client/clientlauncher.cpp
network/clientopcodes.cpp
network/toclientpacket.cpp
${minetest_SCRIPT_SRCS}