summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorShadowNinja <shadowninja@minetest.net>2015-05-04 18:46:49 -0400
committerest31 <MTest31@outlook.com>2015-05-05 17:13:05 +0200
commit1be2d32fd502eeb68bd63fb07b0325b25ee357bd (patch)
treec1c1481f91d0d933a65459354cf979d461557223 /src/CMakeLists.txt
parentdfd790930c8c1464ead730999c3ac9677d130360 (diff)
downloadminetest-1be2d32fd502eeb68bd63fb07b0325b25ee357bd.tar.gz
minetest-1be2d32fd502eeb68bd63fb07b0325b25ee357bd.tar.bz2
minetest-1be2d32fd502eeb68bd63fb07b0325b25ee357bd.zip
Make Git version detection use VERSION_STRING instead of tags
This fixes the problem where 0.4.12-dev versions were erroneously shown as 0.4.11-dev because the tag was added on a separate branch. It also fixes a similar issue when builders didn't fetch new tags when updating. This also removes the number-of-commits-since-tag field, since it's incompatible with this. Said field doesn't seem to be useful anyway if you have the commit hash.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 66c8170cb..044afa367 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -269,7 +269,7 @@ add_custom_target(GenerateVersion
-D "GENERATE_VERSION_SOURCE_DIR=${CMAKE_CURRENT_SOURCE_DIR}"
-D "GENERATE_VERSION_BINARY_DIR=${CMAKE_CURRENT_BINARY_DIR}"
-D "VERSION_STRING=${VERSION_STRING}"
- -D "VERSION_EXTRA=${VERSION_EXTRA}"
+ -D "DEVELOPMENT_BUILD=${DEVELOPMENT_BUILD}"
-P "${CMAKE_SOURCE_DIR}/cmake/Modules/GenerateVersion.cmake"
WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}")