summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authoradrido <addi@king-arthur.eu>2016-10-29 18:01:37 +0200
committerparamat <mat.gregory@virginmedia.com>2016-11-07 21:55:01 +0000
commit295232667eb25f6eef9ed3b06d6a71a5cdcc9476 (patch)
treea7432ca01fb551d717cfe75d88420f94ce4e1297 /src/CMakeLists.txt
parentad4bf2ccf966ac21b94f1778a017ac98f8957ab6 (diff)
downloadminetest-295232667eb25f6eef9ed3b06d6a71a5cdcc9476.tar.gz
minetest-295232667eb25f6eef9ed3b06d6a71a5cdcc9476.tar.bz2
minetest-295232667eb25f6eef9ed3b06d6a71a5cdcc9476.zip
Windows: Add manifest file and set "High DPI Aware" true
This resolves washy font and incorrect mouse handling on Windows if a screen with high DPI is used.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cb04c9425..1983bb078 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -474,6 +474,7 @@ set(common_SRCS
# This gives us the icon and file version information
if(WIN32)
set(WINRESOURCE_FILE "${CMAKE_CURRENT_SOURCE_DIR}/../misc/winresource.rc")
+ set(MINETEST_EXE_MANIFEST_FILE "${CMAKE_CURRENT_SOURCE_DIR}/../misc/minetest.exe.manifest")
if(MINGW)
if(NOT CMAKE_RC_COMPILER)
set(CMAKE_RC_COMPILER "windres.exe")
@@ -486,7 +487,7 @@ if(WIN32)
DEPENDS ${WINRESOURCE_FILE})
SET(common_SRCS ${common_SRCS} ${CMAKE_CURRENT_BINARY_DIR}/winresource_rc.o)
else(MINGW) # Probably MSVC
- set(common_SRCS ${common_SRCS} ${WINRESOURCE_FILE})
+ set(common_SRCS ${common_SRCS} ${WINRESOURCE_FILE} ${MINETEST_EXE_MANIFEST_FILE})
endif(MINGW)
endif()