summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Blot <nerzhul@users.noreply.github.com>2017-04-02 10:51:50 +0200
committerGitHub <noreply@github.com>2017-04-02 10:51:50 +0200
commit86b1542181a92841d174e1caec94d084a34e5158 (patch)
treef18378dd6aa5959b28c5ff8eed19084a288acd1d /src/CMakeLists.txt
parent75fb3e47308823cf39d4aae0fd739ca445e8e36c (diff)
downloadminetest-86b1542181a92841d174e1caec94d084a34e5158.tar.gz
minetest-86b1542181a92841d174e1caec94d084a34e5158.tar.bz2
minetest-86b1542181a92841d174e1caec94d084a34e5158.zip
Update embedded jsoncpp from unk version to 0.10.6 + move libs to lib/ instead of src/ (#5473)
* Update embedded jsoncpp from unk version to 0.10.6 0.10.6 is last release without c++11 * Make jsoncpp more compliant with its amalgamate Jsoncpp cpp file should be upper, make the library like it does in amalgamate * Reorganization: move minetest embedded libs outside of source tree to /lib * Fix a dead grep in LINT
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 30e6c85e4..e11c32df9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -156,26 +156,6 @@ if(ENABLE_FREETYPE)
endif()
endif(ENABLE_FREETYPE)
-# LuaJIT
-option(ENABLE_LUAJIT "Enable LuaJIT support" TRUE)
-set(USE_LUAJIT FALSE)
-if(ENABLE_LUAJIT)
- find_package(LuaJIT)
- if(LUAJIT_FOUND)
- set(USE_LUAJIT TRUE)
- endif(LUAJIT_FOUND)
-else()
- message (STATUS "LuaJIT detection disabled! (ENABLE_LUAJIT=0)")
-endif()
-if(NOT USE_LUAJIT)
- message(STATUS "LuaJIT not found, using bundled Lua.")
- set(LUA_LIBRARY "lua")
- set(LUA_INCLUDE_DIR "${PROJECT_SOURCE_DIR}/lua/src")
- add_subdirectory(lua)
-endif()
-
-find_package(GMP REQUIRED)
-
option(ENABLE_CURSES "Enable ncurses console" TRUE)
set(USE_CURSES FALSE)
@@ -253,7 +233,6 @@ endif(ENABLE_REDIS)
find_package(SQLite3 REQUIRED)
-find_package(Json REQUIRED)
OPTION(ENABLE_SPATIAL "Enable SpatialIndex AreaStore backend" TRUE)
set(USE_SPATIAL FALSE)