summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorPerttu Ahola <celeron55@gmail.com>2011-02-16 20:03:31 +0200
committerPerttu Ahola <celeron55@gmail.com>2011-02-16 20:03:31 +0200
commit92432a28c00699e233cac46aa93d140994d25b14 (patch)
tree601855206cfdaa3473690207cf5b6e287aa31e4e /src/CMakeLists.txt
parente06751aea05ae407faff05d0788c91ad44c70063 (diff)
downloadminetest-92432a28c00699e233cac46aa93d140994d25b14.tar.gz
minetest-92432a28c00699e233cac46aa93d140994d25b14.tar.bz2
minetest-92432a28c00699e233cac46aa93d140994d25b14.zip
small fixes: crack texture, server build on windows, configuration file example, adding config file example to install
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1c684b0fe..c0301cc80 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -151,7 +151,7 @@ if(MSVC)
if(BUILD_SERVER)
set_target_properties(minetestserver PROPERTIES
- COMPILE_DEFINITIONS "/D SERVER")
+ COMPILE_DEFINITIONS "SERVER")
endif(BUILD_SERVER)
else()
@@ -184,6 +184,9 @@ endif()
# Installation
#
+# Example configuration file
+install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/../minetest.conf.example" DESTINATION ${EXAMPLE_CONF_DIR})
+
if(BUILD_CLIENT)
install(TARGETS minetest DESTINATION ${BINDIR})