summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRogier <rogier777@gmail.com>2016-10-09 17:57:18 +0200
committerNer'zhul <nerzhul@users.noreply.github.com>2016-10-11 07:29:04 +0200
commita4a9ee94f3aff59fcb9e8f8e31409843564ef6fb (patch)
tree69d9c79925839d53290fc6f1bd1e2c51efd3ea45 /src/CMakeLists.txt
parent1b450861f01eef98c7d4f7810724d6bec7423a7c (diff)
downloadminetest-a4a9ee94f3aff59fcb9e8f8e31409843564ef6fb.tar.gz
minetest-a4a9ee94f3aff59fcb9e8f8e31409843564ef6fb.tar.bz2
minetest-a4a9ee94f3aff59fcb9e8f8e31409843564ef6fb.zip
Disable cmake message concerning WIN32 on non-windows systems
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8e3ae95ab..3eda27953 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -726,7 +726,7 @@ else()
set(OTHER_FLAGS "${OTHER_FLAGS} -Wsign-compare")
endif()
- if(NOT ZLIBWAPI_DLL AND CMAKE_SIZEOF_VOID_P EQUAL 4)
+ if(WIN32 AND NOT ZLIBWAPI_DLL AND CMAKE_SIZEOF_VOID_P EQUAL 4)
set(OTHER_FLAGS "${OTHER_FLAGS} -DWIN32_NO_ZLIB_WINAPI")
message(WARNING "Defaulting to cdecl for zlib on win32 because ZLIBWAPI_DLL"
" isn't set, ensure that ZLIBWAPI_DLL is set if you want stdcall.")