summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKahrl <kahrl@gmx.net>2011-09-08 01:08:47 +0200
committerKahrl <kahrl@gmx.net>2011-09-08 01:08:47 +0200
commitbaf7da9d4a7fc0566840b159903999d76d99a228 (patch)
tree66ed23105449fcf51e971d5f8fcbf03d04973fb7 /src/CMakeLists.txt
parentc0b35fa429c68b49b2d6a5124aff6dcc31400b63 (diff)
downloadminetest-baf7da9d4a7fc0566840b159903999d76d99a228.tar.gz
minetest-baf7da9d4a7fc0566840b159903999d76d99a228.tar.bz2
minetest-baf7da9d4a7fc0566840b159903999d76d99a228.zip
Collected and moved existing camera infrastructure from game.cpp to camera.cpp and camera.h. Introduced configuration settings 'fov' which chooses the camera's (vertical) field of view and 'view_bobbing' which currently does nothing. Other code refactored to not expect the FOV to be a build time constant.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9c3b0960a..80ee0fc64 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -142,6 +142,7 @@ set(minetest_SRCS
mapblock_mesh.cpp
farmesh.cpp
keycode.cpp
+ camera.cpp
clouds.cpp
clientobject.cpp
guiMainMenu.cpp