summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Reilova <rafael7@users.noreply.github.com>2014-11-16 21:52:24 -0500
committerCraig Robbins <kde.psych@gmail.com>2014-11-21 22:33:48 +1000
commitf7d65091f83abe1cb1a70d6823291df8accbe6ab (patch)
tree6955cb513a7d92e9db775e33e18389dfc2738667 /src/CMakeLists.txt
parentd406ac994b8092c5bd2dc32eda1a2eafbf95a30c (diff)
downloadminetest-f7d65091f83abe1cb1a70d6823291df8accbe6ab.tar.gz
minetest-f7d65091f83abe1cb1a70d6823291df8accbe6ab.tar.bz2
minetest-f7d65091f83abe1cb1a70d6823291df8accbe6ab.zip
serialize.h: use machine native byte swapping if available, fall-back to previous generic method if not (supported for GCC using endian.h, detection done in cmake) write/readARGB8() - just write 32-bit color in one op, instead of 4 1-byte ops cleanup: removed unneeded buffer init for some serialize-out functions use a #define for the fixed point factor in read/writeF1000()
nodemetadata.cpp, nodetimer.cpp optimzation: simpler deserialize node position method staticobject.cpp: cleanup: use util/serialize.h inlines instead of its own de/serialization serialize.cpp: minor optimization/cleanup: avoid generation of unneeded string temporary CMakeLists.txt, cmake_config.h.in: detection of endian.h config.h: added HAVE_ENDIAN_H Commits due to feedback squashed Signed-off-by: Craig Robbins <kde.psych@gmail.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b1fd26247..ec6c7fbac 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -2,6 +2,7 @@ project(minetest)
cmake_minimum_required( VERSION 2.6 )
INCLUDE(CheckCSourceRuns)
+INCLUDE(CheckIncludeFiles)
# Set some random things default to not being visible in the GUI
mark_as_advanced(EXECUTABLE_OUTPUT_PATH LIBRARY_OUTPUT_PATH)
@@ -313,6 +314,8 @@ if(ENABLE_REDIS)
endif(REDIS_LIBRARY AND REDIS_INCLUDE_DIR)
endif(ENABLE_REDIS)
+CHECK_INCLUDE_FILES(endian.h HAVE_ENDIAN_H)
+
configure_file(
"${PROJECT_SOURCE_DIR}/cmake_config.h.in"
"${PROJECT_BINARY_DIR}/cmake_config.h"