aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsfan5 <sfan5@live.de>2021-10-25 22:33:13 +0200
committerrubenwardy <rw@rubenwardy.com>2021-10-31 22:32:48 +0000
commit0b95da7ad3f36ad49e3dfb9d7e919d5f9fc8f57a (patch)
treed87b74739863c6931a3b95f91c7155645baa7878 /src/CMakeLists.txt
parentea1396f85693ee1f752219d91adcacb32041fc84 (diff)
downloadminetest-0b95da7ad3f36ad49e3dfb9d7e919d5f9fc8f57a.tar.gz
minetest-0b95da7ad3f36ad49e3dfb9d7e919d5f9fc8f57a.tar.bz2
minetest-0b95da7ad3f36ad49e3dfb9d7e919d5f9fc8f57a.zip
Automatically package MinGW runtime in buildbot
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7ae5c15d4..1549587b7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -278,10 +278,12 @@ if(WIN32)
endif()
set(PLATFORM_LIBS ws2_32.lib version.lib shlwapi.lib ${PLATFORM_LIBS})
+ set(EXTRA_DLL "" CACHE FILEPATH "Optional paths to additional DLLs that should be packaged")
+
# DLLs are automatically copied to the output directory by vcpkg when VCPKG_APPLOCAL_DEPS=ON
if(NOT VCPKG_APPLOCAL_DEPS)
- find_file(ZLIB_DLL NAMES "" DOC "Path to Zlib DLL for installation (optional)")
- find_file(ZSTD_DLL NAMES "" DOC "Path to Zstd DLL for installation (optional)")
+ set(ZLIB_DLL "" CACHE FILEPATH "Path to Zlib DLL for installation (optional)")
+ set(ZSTD_DLL "" CACHE FILEPATH "Path to Zstd DLL for installation (optional)")
if(ENABLE_SOUND)
set(OPENAL_DLL "" CACHE FILEPATH "Path to OpenAL32.dll for installation (optional)")
set(OGG_DLL "" CACHE FILEPATH "Path to libogg.dll for installation (optional)")
@@ -294,7 +296,6 @@ if(WIN32)
set(LUA_DLL "" CACHE FILEPATH "Path to luajit-5.1.dll for installation (optional)")
endif()
endif()
-
else()
# Unix probably
if(BUILD_CLIENT)
@@ -794,6 +795,9 @@ endif()
# Installation
if(WIN32)
+ if(EXTRA_DLL)
+ install(FILES ${EXTRA_DLL} DESTINATION ${BINDIR})
+ endif()
if(VCPKG_APPLOCAL_DEPS)
# Collect the dll's from the output path
install(DIRECTORY ${EXECUTABLE_OUTPUT_PATH}/Release/