summaryrefslogtreecommitdiff
path: root/src/cguittfont/CMakeLists.txt
diff options
context:
space:
mode:
authorWeblate <42@minetest.ru>2013-02-28 18:03:28 +0100
committerWeblate <42@minetest.ru>2013-02-28 18:03:28 +0100
commit22e186b4aa88b585e71500c4e9a03bf69b0b6191 (patch)
tree14c5b7a73cf144ba7cf3066caac088a200f81a72 /src/cguittfont/CMakeLists.txt
parent372acf7b8eca0614a4a0da93cfbaccbcd459b36b (diff)
parentd31f07bd4b83f858cce589faac56922e12ba670f (diff)
downloadminetest-22e186b4aa88b585e71500c4e9a03bf69b0b6191.tar.gz
minetest-22e186b4aa88b585e71500c4e9a03bf69b0b6191.tar.bz2
minetest-22e186b4aa88b585e71500c4e9a03bf69b0b6191.zip
Merge remote branch 'origin/master'
Diffstat (limited to 'src/cguittfont/CMakeLists.txt')
-rw-r--r--src/cguittfont/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/cguittfont/CMakeLists.txt b/src/cguittfont/CMakeLists.txt
new file mode 100644
index 000000000..94d061462
--- /dev/null
+++ b/src/cguittfont/CMakeLists.txt
@@ -0,0 +1,17 @@
+include_directories(
+ ${IRRLICHT_INCLUDE_DIR}
+ ${FREETYPE_INCLUDE_DIRS}
+)
+
+# CGUITTFont authors, y u no include headers you use?
+# Do not add CGUITTFont.cpp to the line below.
+# xCGUITTFont.cpp is a wrapper file that includes
+# additional required headers.
+add_library(cguittfont xCGUITTFont.cpp)
+
+target_link_libraries(
+ cguittfont
+ ${IRRLICHT_LIBRARY}
+ ${FREETYPE_LIBRARY}
+ ${ZLIB_LIBRARIES} # needed by freetype, repeated here for safety
+)