summaryrefslogtreecommitdiff
path: root/src/script/CMakeLists.txt
diff options
context:
space:
mode:
authorsapier <Sapier at GMX dot net>2013-05-25 00:51:02 +0200
committerKahrl <kahrl@gmx.net>2013-05-25 00:51:02 +0200
commitab433775777c4f5055bcf4d2a1cffc506c4f9961 (patch)
tree9f80c74c95cbb1efa15c0c36df8d5e35235e5554 /src/script/CMakeLists.txt
parent865f380c91ced850d1a499c91aa2ab5489624802 (diff)
downloadminetest-ab433775777c4f5055bcf4d2a1cffc506c4f9961.tar.gz
minetest-ab433775777c4f5055bcf4d2a1cffc506c4f9961.tar.bz2
minetest-ab433775777c4f5055bcf4d2a1cffc506c4f9961.zip
Move scriptapi to separate folder (by sapier)
On the lua side, notably minetest.env:<function>(<args>) should now be replaced by minetest.<function>(<args>). The old way is and will stay supported for a long time. Also: Update and clean up lua_api.txt (by celeron55) Move EnvRef to lua and remove add_rat and add_firefly (by kahrl) Add separate src/util/CMakeLists.txt, other minor fixes (by kahrl)
Diffstat (limited to 'src/script/CMakeLists.txt')
-rw-r--r--src/script/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/script/CMakeLists.txt b/src/script/CMakeLists.txt
new file mode 100644
index 000000000..e1a03b95a
--- /dev/null
+++ b/src/script/CMakeLists.txt
@@ -0,0 +1,9 @@
+add_subdirectory(common)
+add_subdirectory(cpp_api)
+add_subdirectory(lua_api)
+
+set(SCRIPT_SRCS
+ ${SCRIPT_COMMON_SRCS}
+ ${SCRIPT_CPP_API_SRCS}
+ ${SCRIPT_LUA_API_SRCS}
+ PARENT_SCOPE)