summaryrefslogtreecommitdiff
path: root/src/unittest/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Blot <nerzhul@users.noreply.github.com>2018-01-01 18:48:52 +0100
committerGitHub <noreply@github.com>2018-01-01 18:48:52 +0100
commit0d6b58a772d515824afd83e8d9cfa9d2e56a1f91 (patch)
tree4e9920e88be4bb77ebae7a3dab237af231a4314e /src/unittest/CMakeLists.txt
parent9f6d84aee33e1eb14b542fa36f82e0cd7b29e25c (diff)
downloadminetest-0d6b58a772d515824afd83e8d9cfa9d2e56a1f91.tar.gz
minetest-0d6b58a772d515824afd83e8d9cfa9d2e56a1f91.tar.bz2
minetest-0d6b58a772d515824afd83e8d9cfa9d2e56a1f91.zip
Add unittests on ActiveObject and BanManager class (#6866)
* Add unittests on ActiveObject and BanManager class This also permit to fix a bug in ban manager setting bans modified when no modification occurs
Diffstat (limited to 'src/unittest/CMakeLists.txt')
-rw-r--r--src/unittest/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/unittest/CMakeLists.txt b/src/unittest/CMakeLists.txt
index 3a4450fac..f56560666 100644
--- a/src/unittest/CMakeLists.txt
+++ b/src/unittest/CMakeLists.txt
@@ -1,6 +1,8 @@
set (UNITTEST_SRCS
${CMAKE_CURRENT_SOURCE_DIR}/test.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/test_activeobject.cpp
${CMAKE_CURRENT_SOURCE_DIR}/test_areastore.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/test_ban.cpp
${CMAKE_CURRENT_SOURCE_DIR}/test_collision.cpp
${CMAKE_CURRENT_SOURCE_DIR}/test_compression.cpp
${CMAKE_CURRENT_SOURCE_DIR}/test_connection.cpp