summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000..53999e022
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 2.6)
+if(${CMAKE_VERSION} STREQUAL "2.8.2")
+ # bug http://vtk.org/Bug/view.php?id=11020
+ message( WARNING "CMake/CPack version 2.8.2 will not create working .deb packages!")
+endif(${CMAKE_VERSION} STREQUAL "2.8.2")
+
+set(CMAKE_BUILD_TYPE Debug)
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
+
+# This is done here so that IRRDIR is relative to the typical cmake call directory
+find_package(Irrlicht)
+
+# This way the CMakeLists.txt file in src/ is processed
+add_subdirectory(src)
+