summaryrefslogtreecommitdiff
path: root/lib/catch2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/catch2/CMakeLists.txt')
-rw-r--r--lib/catch2/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/lib/catch2/CMakeLists.txt b/lib/catch2/CMakeLists.txt
new file mode 100644
index 000000000..3c471d49d
--- /dev/null
+++ b/lib/catch2/CMakeLists.txt
@@ -0,0 +1,16 @@
+# catch2 is distributed as a standalone header.
+#
+# Downloaded from:
+#
+# https://github.com/catchorg/Catch2/releases/download/v2.13.9/catch.hpp
+#
+# The following changes were made to always print in microseconds, fixed format:
+#
+# - explicit Duration(double inNanoseconds, Unit units = Unit::Auto)
+# + explicit Duration(double inNanoseconds, Unit units = Unit::Microseconds)
+#
+# - return os << duration.value() << ' ' << duration.unitsAsString();
+# + return os << std::fixed << duration.value() << ' ' << duration.unitsAsString();
+
+add_library(catch2 INTERFACE)
+target_include_directories(catch2 INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})