summaryrefslogtreecommitdiff
path: root/lib/jsoncpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/jsoncpp/CMakeLists.txt')
-rw-r--r--lib/jsoncpp/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/jsoncpp/CMakeLists.txt b/lib/jsoncpp/CMakeLists.txt
new file mode 100644
index 000000000..9056e4b6d
--- /dev/null
+++ b/lib/jsoncpp/CMakeLists.txt
@@ -0,0 +1,7 @@
+if(MSVC)
+ set(CMAKE_CXX_FLAGS_RELEASE "/MT /O2 /Ob2 /D NDEBUG")
+endif()
+
+add_library(jsoncpp jsoncpp.cpp)
+target_link_libraries(jsoncpp)
+