summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 929dbacad..ce1cc30bf 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -355,6 +355,10 @@ add_subdirectory(jthread)
add_subdirectory(script)
add_subdirectory(util)
+set (unittests_SRCS
+ test.cpp
+)
+
set(common_SRCS
ban.cpp
base64.cpp
@@ -422,7 +426,6 @@ set(common_SRCS
sound.cpp
staticobject.cpp
subgame.cpp
- test.cpp
tool.cpp
treegen.cpp
version.cpp
@@ -435,6 +438,7 @@ set(common_SRCS
${JTHREAD_SRCS}
${common_SCRIPT_SRCS}
${UTIL_SRCS}
+ ${unittests_SRCS}
)
# This gives us the icon and file version information