summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c384286d4..89be91413 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -590,6 +590,7 @@ else()
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
# clang does not understand __extern_always_inline but libc headers use it
set(OTHER_FLAGS "${OTHER_FLAGS} \"-D__extern_always_inline=extern __always_inline\"")
+ set(OTHER_FLAGS "${OTHER_FLAGS} -Wsign-compare")
endif()
if(MINGW)