summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d56ec18c0..2ce108681 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -737,7 +737,20 @@ if(WIN32)
endif()
if(BUILD_CLIENT)
- install(TARGETS ${PROJECT_NAME} DESTINATION ${BINDIR})
+ install(TARGETS ${PROJECT_NAME}
+ RUNTIME DESTINATION ${BINDIR}
+ LIBRARY DESTINATION ${BINDIR}
+ ARCHIVE DESTINATION ${BINDIR}
+ BUNDLE DESTINATION .
+ )
+
+ if(APPLE)
+ install(CODE "
+ set(BU_CHMOD_BUNDLE_ITEMS ON)
+ include(BundleUtilities)
+ fixup_bundle(\"\${CMAKE_INSTALL_PREFIX}/${BUNDLE_PATH}\" \"\" \"\${CMAKE_INSTALL_PREFIX}/${BINDIR}\")
+ " COMPONENT Runtime)
+ endif()
if(USE_GETTEXT)
foreach(LOCALE ${GETTEXT_AVAILABLE_LOCALES})