summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ce1cc30bf..3bf803ea0 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -352,6 +352,7 @@ add_custom_target(GenerateVersion
WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}")
add_subdirectory(jthread)
+add_subdirectory(network)
add_subdirectory(script)
add_subdirectory(util)
@@ -431,10 +432,7 @@ set(common_SRCS
version.cpp
voxel.cpp
voxelalgorithms.cpp
- network/connection.cpp
- network/networkpacket.cpp
- network/packethandlers/server.cpp
- network/serveropcodes.cpp
+ ${common_network_SRCS}
${JTHREAD_SRCS}
${common_SCRIPT_SRCS}
${UTIL_SRCS}
@@ -461,9 +459,16 @@ if(WIN32)
endif()
# Client sources
+
+if (BUILD_CLIENT)
+ add_subdirectory(client)
+endif(BUILD_CLIENT)
+
set(minetest_SRCS
${common_SRCS}
${sound_SRCS}
+ ${client_SRCS}
+ ${client_network_SRCS}
camera.cpp
chat.cpp
client.cpp
@@ -498,9 +503,6 @@ set(minetest_SRCS
sky.cpp
tile.cpp
wieldmesh.cpp
- client/clientlauncher.cpp
- network/clientopcodes.cpp
- network/packethandlers/client.cpp
${minetest_SCRIPT_SRCS}
)
list(SORT minetest_SRCS)