summaryrefslogtreecommitdiff
path: root/src/cguittfont/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/cguittfont/CMakeLists.txt')
-rw-r--r--src/cguittfont/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/cguittfont/CMakeLists.txt b/src/cguittfont/CMakeLists.txt
new file mode 100644
index 000000000..94d061462
--- /dev/null
+++ b/src/cguittfont/CMakeLists.txt
@@ -0,0 +1,17 @@
+include_directories(
+ ${IRRLICHT_INCLUDE_DIR}
+ ${FREETYPE_INCLUDE_DIRS}
+)
+
+# CGUITTFont authors, y u no include headers you use?
+# Do not add CGUITTFont.cpp to the line below.
+# xCGUITTFont.cpp is a wrapper file that includes
+# additional required headers.
+add_library(cguittfont xCGUITTFont.cpp)
+
+target_link_libraries(
+ cguittfont
+ ${IRRLICHT_LIBRARY}
+ ${FREETYPE_LIBRARY}
+ ${ZLIB_LIBRARIES} # needed by freetype, repeated here for safety
+)