summaryrefslogtreecommitdiff
path: root/src/lua/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/lua/src/CMakeLists.txt')
-rw-r--r--src/lua/src/CMakeLists.txt54
1 files changed, 0 insertions, 54 deletions
diff --git a/src/lua/src/CMakeLists.txt b/src/lua/src/CMakeLists.txt
deleted file mode 100644
index 8f6cc1213..000000000
--- a/src/lua/src/CMakeLists.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-
-# Lua core source files.
-set(LUA_CORE_SRC
- lapi.c
- lauxlib.c
- lbaselib.c
- lcode.c
- ldblib.c
- ldebug.c
- ldo.c
- ldump.c
- lfunc.c
- lgc.c
- linit.c
- liolib.c
- llex.c
- lmathlib.c
- lmem.c
- loadlib.c
- lobject.c
- lopcodes.c
- loslib.c
- lparser.c
- lstate.c
- lstring.c
- lstrlib.c
- ltable.c
- ltablib.c
- ltm.c
- lundump.c
- lvm.c
- lzio.c
-)
-set(LUA_LIB_HEADERS
- lua.h
- lualib.h
- lauxlib.h
- luaconf.h
-)
-
-include_directories(${CMAKE_CURRENT_SOURCE_DIR}
- ${CMAKE_CURRENT_BINARY_DIR})
-
-# Lua library.
-add_library(lua STATIC ${LUA_CORE_SRC})
-target_link_libraries(lua ${LIBS})
-set(LUA_STATIC_LIB lua)
-set(LUA_LIBS lua)
-
-set_target_properties(${LUA_LIBS} PROPERTIES
- VERSION ${LUA_VERSION}
- CLEAN_DIRECT_OUTPUT 1
-)
-