summaryrefslogtreecommitdiff
path: root/src/script/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/script/CMakeLists.txt')
-rw-r--r--src/script/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/script/CMakeLists.txt b/src/script/CMakeLists.txt
new file mode 100644
index 000000000..e1a03b95a
--- /dev/null
+++ b/src/script/CMakeLists.txt
@@ -0,0 +1,9 @@
+add_subdirectory(common)
+add_subdirectory(cpp_api)
+add_subdirectory(lua_api)
+
+set(SCRIPT_SRCS
+ ${SCRIPT_COMMON_SRCS}
+ ${SCRIPT_CPP_API_SRCS}
+ ${SCRIPT_LUA_API_SRCS}
+ PARENT_SCOPE)