summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMetaDucky <metaducky AT gmail DOT com>2013-05-26 09:49:02 +0200
committerSfan5 <sfan5@live.de>2013-06-13 16:45:52 +0200
commit40b2f36eb8a93557c0e0957267992534452e091f (patch)
treecb43810b8301b2e99ed6d7260dcecfc30e8b65ca /CMakeLists.txt
parent7a58c1d4ca7a59f05043ff3c2caeab16c0a78a0d (diff)
downloadminetest-40b2f36eb8a93557c0e0957267992534452e091f.tar.gz
minetest-40b2f36eb8a93557c0e0957267992534452e091f.tar.bz2
minetest-40b2f36eb8a93557c0e0957267992534452e091f.zip
Fixes cmake-gui causing RUN_IN_PLACE to be always off
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4072bae3..5c8753e78 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,13 @@ else()
set(RUN_IN_PLACE 0 CACHE BOOL "Run directly in source directory structure")
endif()
+# RUN_IN_PLACE is exported as a #define value, ensure it's 1/0 instead of ON/OFF
+if(RUN_IN_PLACE)
+ set(RUN_IN_PLACE 1)
+else()
+ set(RUN_IN_PLACE 0)
+endif()
+
set(BUILD_CLIENT 1 CACHE BOOL "Build client")
if(WIN32)
set(BUILD_SERVER 0 CACHE BOOL "Build server")