summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPerttu Ahola <celeron55@gmail.com>2012-03-20 00:52:53 +0200
committerPerttu Ahola <celeron55@gmail.com>2012-03-20 01:06:58 +0200
commitdb4911f9565cae6d982e5fac2627fe45048fab8f (patch)
treeb8d72c6cf2290da16eb69d47b9aeb1785c1b17ce /CMakeLists.txt
parent2a325de7aa943ea2a50cc4190b78c4a72529192d (diff)
downloadminetest-db4911f9565cae6d982e5fac2627fe45048fab8f.tar.gz
minetest-db4911f9565cae6d982e5fac2627fe45048fab8f.tar.bz2
minetest-db4911f9565cae6d982e5fac2627fe45048fab8f.zip
Fix for MSVC and move stuff around a bit in CMakeLists.txt and src/CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 257df6cec..c6f878823 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -84,8 +84,12 @@ elseif(UNIX) # Linux, BSD etc
endif()
endif()
-install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/builtin" DESTINATION "${SHAREDIR}/")
-install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/games/mesetint" DESTINATION "${SHAREDIR}/games/")
+install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/builtin" DESTINATION "${SHAREDIR}")
+install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/games/mesetint" DESTINATION "${SHAREDIR}/games")
+if(BUILD_CLIENT)
+ #install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/sounds/base/pack" DESTINATION "${SHAREDIR}/sounds/base")
+ install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/textures/base/pack" DESTINATION "${SHAREDIR}/textures/base")
+endif()
install(FILES "README.txt" DESTINATION "${DOCDIR}")
install(FILES "minetest.conf.example" DESTINATION "${EXAMPLE_CONF_DIR}")