summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWuzzy <wuzzy2@mail.ru>2021-04-23 19:37:45 +0000
committerGitHub <noreply@github.com>2021-04-23 21:37:45 +0200
commit776015c350bc0210a13dd1a077c086cb81314c09 (patch)
tree36b56e676284bf8ec8e942d340d9aff737f85b91 /CMakeLists.txt
parent074e6a67def42ab9c91b8638c914869d516a9cd7 (diff)
downloadminetest-776015c350bc0210a13dd1a077c086cb81314c09.tar.gz
minetest-776015c350bc0210a13dd1a077c086cb81314c09.tar.bz2
minetest-776015c350bc0210a13dd1a077c086cb81314c09.zip
Rename “Irrlicht” to “IrrlichtMt” in documentation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c46ff6c77..1f90847ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,9 +60,9 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
# This is done here so that relative search paths are more reasonable
find_package(Irrlicht)
if(BUILD_CLIENT AND NOT IRRLICHT_FOUND)
- message(FATAL_ERROR "Irrlicht is required to build the client, but it was not found.")
+ message(FATAL_ERROR "IrrlichtMt is required to build the client, but it was not found.")
elseif(NOT IRRLICHT_INCLUDE_DIR)
- message(FATAL_ERROR "Irrlicht headers are required to build the server, but none found.")
+ message(FATAL_ERROR "Irrlicht or IrrlichtMt headers are required to build the server, but none found.")
endif()
include(CheckSymbolExists)
@@ -71,7 +71,7 @@ unset(HAS_FORKED_IRRLICHT CACHE)
check_symbol_exists(IRRLICHT_VERSION_MT "IrrCompileConfig.h" HAS_FORKED_IRRLICHT)
if(NOT HAS_FORKED_IRRLICHT)
string(CONCAT EXPLANATION_MSG
- "Irrlicht found, but it is not Minetest's Irrlicht fork. "
+ "Irrlicht found, but it is not IrrlichtMt (Minetest's Irrlicht fork). "
"The Minetest team has forked Irrlicht to make their own customizations. "
"It can be found here: https://github.com/minetest/irrlicht")
if(BUILD_CLIENT)