summaryrefslogtreecommitdiff
path: root/lib/lua/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Blot <nerzhul@users.noreply.github.com>2017-04-02 10:51:50 +0200
committerGitHub <noreply@github.com>2017-04-02 10:51:50 +0200
commit86b1542181a92841d174e1caec94d084a34e5158 (patch)
treef18378dd6aa5959b28c5ff8eed19084a288acd1d /lib/lua/src/CMakeLists.txt
parent75fb3e47308823cf39d4aae0fd739ca445e8e36c (diff)
downloadminetest-86b1542181a92841d174e1caec94d084a34e5158.tar.gz
minetest-86b1542181a92841d174e1caec94d084a34e5158.tar.bz2
minetest-86b1542181a92841d174e1caec94d084a34e5158.zip
Update embedded jsoncpp from unk version to 0.10.6 + move libs to lib/ instead of src/ (#5473)
* Update embedded jsoncpp from unk version to 0.10.6 0.10.6 is last release without c++11 * Make jsoncpp more compliant with its amalgamate Jsoncpp cpp file should be upper, make the library like it does in amalgamate * Reorganization: move minetest embedded libs outside of source tree to /lib * Fix a dead grep in LINT
Diffstat (limited to 'lib/lua/src/CMakeLists.txt')
-rw-r--r--lib/lua/src/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/lib/lua/src/CMakeLists.txt b/lib/lua/src/CMakeLists.txt
new file mode 100644
index 000000000..8f6cc1213
--- /dev/null
+++ b/lib/lua/src/CMakeLists.txt
@@ -0,0 +1,54 @@
+
+# Lua core source files.
+set(LUA_CORE_SRC
+ lapi.c
+ lauxlib.c
+ lbaselib.c
+ lcode.c
+ ldblib.c
+ ldebug.c
+ ldo.c
+ ldump.c
+ lfunc.c
+ lgc.c
+ linit.c
+ liolib.c
+ llex.c
+ lmathlib.c
+ lmem.c
+ loadlib.c
+ lobject.c
+ lopcodes.c
+ loslib.c
+ lparser.c
+ lstate.c
+ lstring.c
+ lstrlib.c
+ ltable.c
+ ltablib.c
+ ltm.c
+ lundump.c
+ lvm.c
+ lzio.c
+)
+set(LUA_LIB_HEADERS
+ lua.h
+ lualib.h
+ lauxlib.h
+ luaconf.h
+)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR})
+
+# Lua library.
+add_library(lua STATIC ${LUA_CORE_SRC})
+target_link_libraries(lua ${LIBS})
+set(LUA_STATIC_LIB lua)
+set(LUA_LIBS lua)
+
+set_target_properties(${LUA_LIBS} PROPERTIES
+ VERSION ${LUA_VERSION}
+ CLEAN_DIRECT_OUTPUT 1
+)
+