summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorred-001 <red-001@outlook.ie>2017-06-11 08:43:31 +0100
committerLoïc Blot <nerzhul@users.noreply.github.com>2017-06-11 09:43:31 +0200
commit26e2eb019afa60c66c4dc89cf24bbf5b25c6a383 (patch)
treea2ac098a32d4b7c97775c9161a29b12ec54e3fad /src/CMakeLists.txt
parent6c5e5e202394ce8063e3c2d9b663145bc4f8efce (diff)
downloadminetest-26e2eb019afa60c66c4dc89cf24bbf5b25c6a383.tar.gz
minetest-26e2eb019afa60c66c4dc89cf24bbf5b25c6a383.tar.bz2
minetest-26e2eb019afa60c66c4dc89cf24bbf5b25c6a383.zip
Improve the path select GUI (#5852)
- Allow lua to chose whatever directories or files can be selected - Fix selecting directories - Rename dialog to `guiPathSelectMenu` from `guiFileSelectMenu` - Rename lua function for opening the menu from `show_file_open_dialog` to `show_path_select_dialog` - Remove duplicate code and fix code style. Related changes - fix `clang-format` whitelist. - Regenerate minetest.conf.example
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6963d0306..08ea809c7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -509,7 +509,7 @@ set(client_SRCS
game.cpp
guiChatConsole.cpp
guiEngine.cpp
- guiFileSelectMenu.cpp
+ guiPathSelectMenu.cpp
guiFormSpecMenu.cpp
guiKeyChangeMenu.cpp
guiPasswordChange.cpp