summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJozef Behran <jozuejozef@gmail.com>2019-08-10 23:32:47 +0200
committerSmallJoker <SmallJoker@users.noreply.github.com>2019-08-10 23:32:46 +0200
commit49f100618350e81d98410a874ce30b5c30b32927 (patch)
tree5fefc8152631ba7fb98d4038fa2aeb5f8586f49b /src/CMakeLists.txt
parent120155f312cb1977b9a325acc7c7679103eb3800 (diff)
downloadminetest-49f100618350e81d98410a874ce30b5c30b32927.tar.gz
minetest-49f100618350e81d98410a874ce30b5c30b32927.tar.bz2
minetest-49f100618350e81d98410a874ce30b5c30b32927.zip
Fix breakage of non-GLES2 setups (#8774)
The commit 526a9e4b66abaf83eb6b1aaa3e93375acd87b830 breaks the non-GLES2 setups because the code that is intended to handle that is behind "elseif()" which is interpreted as "elseif(false)" and thus the code never gets executed. Fix that by changing the offending line to else(). Additionally, to avoid breaking the server only build (which shall not have a dependency on GL/GLU/GLES at all), enclose the entire block code in if(BUILD_CLIENT).
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt20
1 files changed, 11 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2627a0b97..ebf5b2871 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -104,15 +104,17 @@ endif()
option(ENABLE_GLES "Use OpenGL ES instead of OpenGL" FALSE)
mark_as_advanced(ENABLE_GLES)
-if(ENABLE_GLES)
- find_package(OpenGLES2 REQUIRED)
-elseif()
- if(NOT WIN32) # Unix probably
- set(OPENGL_GL_PREFERENCE "LEGACY" CACHE STRING
- "See CMake Policy CMP0072 for reference. GLVND is broken on some nvidia setups")
- set(OpenGL_GL_PREFERENCE ${OPENGL_GL_PREFERENCE})
-
- find_package(OpenGL REQUIRED)
+if(BUILD_CLIENT)
+ if(ENABLE_GLES)
+ find_package(OpenGLES2 REQUIRED)
+ else()
+ if(NOT WIN32) # Unix probably
+ set(OPENGL_GL_PREFERENCE "LEGACY" CACHE STRING
+ "See CMake Policy CMP0072 for reference. GLVND is broken on some nvidia setups")
+ set(OpenGL_GL_PREFERENCE ${OPENGL_GL_PREFERENCE})
+
+ find_package(OpenGL REQUIRED)
+ endif()
endif()
endif()