summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHugues Ross <hugues.ross@gmail.com>2020-04-14 14:41:29 -0400
committerGitHub <noreply@github.com>2020-04-14 20:41:29 +0200
commit5cf6318117edcae6bf30d829d9e9dd9dbf1d4bf7 (patch)
treede590965f9f1cf68a4b6ee7ca802aaa5c0b987ee /src/CMakeLists.txt
parent7e21b3cd4883eb8b9eb7e9ca49e50f6f0c7bc0d6 (diff)
downloadminetest-5cf6318117edcae6bf30d829d9e9dd9dbf1d4bf7.tar.gz
minetest-5cf6318117edcae6bf30d829d9e9dd9dbf1d4bf7.tar.bz2
minetest-5cf6318117edcae6bf30d829d9e9dd9dbf1d4bf7.zip
Refactor texture overrides and add new features (#9600)
* Refactor texture overrides, and add new features: - Texture overrides can support multiple targets in one line - Texture override files can have comment lines - Item images/wield images can be overridden * Formatting changes * Address soime feedback - Pass vectors by const reference - Log syntax errors as warnings - Remove 'C' prefix from TextureOverrideSource * Simplify override target checks with an inline helper function * make linter happy * Apply feedback suggestions Co-Authored-By: rubenwardy <rw@rubenwardy.com> * Remove remaining != 0 checks * Update copyright notice Co-authored-by: sfan5 <sfan5@live.de> Co-authored-by: rubenwardy <rw@rubenwardy.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0b550c09c..fa261547b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -423,6 +423,7 @@ set(common_SRCS
settings.cpp
staticobject.cpp
terminal_chat_console.cpp
+ texture_override.cpp
tileanimation.cpp
tool.cpp
translation.cpp