summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authoradrido <robots_only_adrido@gmx.com>2017-07-18 21:29:23 +0200
committerLoïc Blot <nerzhul@users.noreply.github.com>2017-07-18 21:29:23 +0200
commit7e3cdf7088b1fb6744d0bd9cc903823b6e3bbfe3 (patch)
treeeab7dff00d9e91192e83157740f24de6972cc213 /src/CMakeLists.txt
parenta8c405b04ea1be927d8ebc753ce7ccb46cfdd4f9 (diff)
downloadminetest-7e3cdf7088b1fb6744d0bd9cc903823b6e3bbfe3.tar.gz
minetest-7e3cdf7088b1fb6744d0bd9cc903823b6e3bbfe3.tar.bz2
minetest-7e3cdf7088b1fb6744d0bd9cc903823b6e3bbfe3.zip
Copy lua51.dll (luajit) to bindir (#6148)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a7e26af7d..2e624dd7f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -292,6 +292,9 @@ if(WIN32)
set(VORBIS_DLL "" CACHE FILEPATH "Path to libvorbis.dll for installation (optional)")
set(VORBISFILE_DLL "" CACHE FILEPATH "Path to libvorbisfile.dll for installation (optional)")
endif()
+ if(USE_LUAJIT)
+ set(LUA_DLL "" CACHE FILEPATH "Path to lua51.dll for installation (optional)")
+ endif()
else()
# Unix probably
if(BUILD_CLIENT)
@@ -809,6 +812,9 @@ if(WIN32)
if(LEVELDB_DLL)
install(FILES ${LEVELDB_DLL} DESTINATION ${BINDIR})
endif()
+ if(LUA_DLL)
+ install(FILES ${LUA_DLL} DESTINATION ${BINDIR})
+ endif()
endif()
if(BUILD_CLIENT)