summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoic Blot <loic.blot@unix-experience.fr>2015-01-12 17:01:41 +0100
committerCraig Robbins <kde.psych@gmail.com>2015-02-10 20:04:08 +1000
commita704c04f00bfea4b77550169fa08105c2ee0dfd0 (patch)
treef0f56c7845a14d0e583628f026e59eb1f4cfc7b5 /src/CMakeLists.txt
parent15c037614f6f7193cef4bfd1da45d83ef2fef393 (diff)
downloadminetest-a704c04f00bfea4b77550169fa08105c2ee0dfd0.tar.gz
minetest-a704c04f00bfea4b77550169fa08105c2ee0dfd0.tar.bz2
minetest-a704c04f00bfea4b77550169fa08105c2ee0dfd0.zip
Network Layer 7 rework (Packet handling)
* Move networkcode to a dedicated directory * Rename clientserver.h to network/networkprotocol.h (Better name) and sanitize some includes * Create object NetworkPacket * It stores command (opcode) and data separated * It also stores peer_id * Data reading can be done by using a streaming interface * Change packet routing analysis * Remove old conditional analysis * Now uses function pointed analysis and add connection state ({Client,Server}::handlers) * Connection state permit to categorize condition to handle before analyze packets * Create a handler for depreciated messages, instead of duplicating code
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 93083f369..e5245534c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -429,6 +429,9 @@ set(common_SRCS
version.cpp
voxel.cpp
voxelalgorithms.cpp
+ network/networkpacket.cpp
+ network/serveropcodes.cpp
+ network/toserverpacket.cpp
${JTHREAD_SRCS}
${common_SCRIPT_SRCS}
${UTIL_SRCS}
@@ -491,6 +494,8 @@ set(minetest_SRCS
sky.cpp
tile.cpp
wieldmesh.cpp
+ network/clientopcodes.cpp
+ network/toclientpacket.cpp
${minetest_SCRIPT_SRCS}
)
list(SORT minetest_SRCS)