summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Blot <nerzhul@users.noreply.github.com>2017-08-24 08:28:54 +0200
committerGitHub <noreply@github.com>2017-08-24 08:28:54 +0200
commitc7160cb629086df2a32c7dcf4faed4761ec4393e (patch)
tree63670a536ce95f6a3a1ce09bf2f2f65d1bec5214 /src/CMakeLists.txt
parent928609c8bd9d4e6129ab244214bd5c54d000b737 (diff)
downloadminetest-c7160cb629086df2a32c7dcf4faed4761ec4393e.tar.gz
minetest-c7160cb629086df2a32c7dcf4faed4761ec4393e.tar.bz2
minetest-c7160cb629086df2a32c7dcf4faed4761ec4393e.zip
Network cleanup (#6302)
* Cleanup network headers * Move peerhandler to a specific header to reduce compilation times * Move socket.cpp/h to network folder * More work * Network code cleanups * Move socket.{cpp,h} to network folder * Move Address object to network/address.{cpp,h} * Move network exceptions to network/networkexceptions.h * Client: use unique_ptr for Connection * Server/ClientIface: use shared_ptr for Connection * Format fixes * Remove socket.cpp socket.h from clang-format whitelist * Also fix NetworkPacket code style & make it under clang-format
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2e624dd7f..4e76f3b00 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -442,7 +442,6 @@ set(common_SRCS
serverlist.cpp
serverobject.cpp
settings.cpp
- socket.cpp
sound.cpp
staticobject.cpp
subgame.cpp