summaryrefslogtreecommitdiff
path: root/src/cguittfont/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Blot <nerzhul@users.noreply.github.com>2017-06-20 17:18:34 +0200
committerGitHub <noreply@github.com>2017-06-20 17:18:34 +0200
commit16938adfc00b3c56a7b08a9eb97160b68902bae6 (patch)
tree6e818b95c8557872e39f23c00f5a60e09f2f11bc /src/cguittfont/CMakeLists.txt
parent318106223fc7351bd879980c17ee9c4bee65a272 (diff)
downloadminetest-16938adfc00b3c56a7b08a9eb97160b68902bae6.tar.gz
minetest-16938adfc00b3c56a7b08a9eb97160b68902bae6.tar.bz2
minetest-16938adfc00b3c56a7b08a9eb97160b68902bae6.zip
Merge cguittfont lib in irrlicht change folder. (#6016)
* Merge cguittfont lib in irrlicht change folder. This remove hack and static lib for FreeType
Diffstat (limited to 'src/cguittfont/CMakeLists.txt')
-rw-r--r--src/cguittfont/CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/src/cguittfont/CMakeLists.txt b/src/cguittfont/CMakeLists.txt
deleted file mode 100644
index 6cd35f310..000000000
--- a/src/cguittfont/CMakeLists.txt
+++ /dev/null
@@ -1,30 +0,0 @@
-# CGUITTFont authors, y u no include headers you use?
-# Do not add CGUITTFont.cpp to the line below.
-# xCGUITTFont.cpp is a wrapper file that includes
-# additional required headers.
-add_library(cguittfont STATIC xCGUITTFont.cpp)
-
-if(FREETYPE_PKGCONFIG_FOUND)
- set_target_properties(cguittfont
- PROPERTIES
- COMPILE_FLAGS "${FREETYPE_CFLAGS_STR}"
- LINK_FLAGS "${FREETYPE_LDFLAGS_STR}"
- )
-
- include_directories(
- ${IRRLICHT_INCLUDE_DIR}
- )
-else(FREETYPE_PKGCONFIG_FOUND)
- include_directories(
- ${IRRLICHT_INCLUDE_DIR}
- ${FREETYPE_INCLUDE_DIRS}
- )
-endif(FREETYPE_PKGCONFIG_FOUND)
-
-target_link_libraries(
- cguittfont
- ${IRRLICHT_LIBRARY}
- ${FREETYPE_LIBRARY}
- ${ZLIB_LIBRARIES} # needed by freetype, repeated here for safety
- )
-